SymNet Designer Version 5.0 Release Notes

Copyright 2004, Symetrix, Inc.

 

Overview of contents of this file

Introduction

I) Changes from previous versions

II) Installation Notes

III) Upgrading Firmware for V5.0

IV) Issues with Site files from previous versions of SymNet Designer

 

Introduction

 

This document is intended for those users upgrading from Version 4.x. If you are upgrading from an earlier version, you may also want to review the release notes from the relevant intermediate releases (e.g. V3.5, V3.0, etc.). These can be found on the SymNet web site.

 

I) Changes from previous versions

Main New V5.0 Features (compared to V4.0x)

SymNet Designer V5.0 is a major release and has many enhancements compared to V4.0x.

 

1) Support for a new family of devices, SymNet Express, has been added. Seven different configurations are available including four “Express Cobra” versions with CobraNet. See the SymNet web site for more information about these exciting new products.
Note: To communicate with Express Cobra units, CobraLink devices must use CM-1 firmware V2.9.6 or newer.

 

2) SymNet hardware now remembers its last state on power-down and optionally restores all parameters upon power-up. In previous versions, SymNet hardware could remember the last recalled preset on power-up, but other non-preset changes were not saved. This feature is turned off for backward compatibility by default, but can be enabled from the Triggers and Power On Default dialog box (“Load last parameter settings at power on”).

 

3) A new module called “British EQ” has been added. It emulates the channel strip equalization on a typical analog mixing console providing low shelving, 3 sweepable mids, high shelving, and a low-cut (rumble) filter in a single module. Mono and stereo versions are available.

 

4) Stereo input/stereo output mixer modules have been added. These Stereo/Stereo Mixer modules allow controlling a stereo signal from a single fader. The existing modules which used to be called Stereo Mixers have been renamed Mono/Stereo Mixers. The existing mono mixer modules have been renamed “Mono/Mono Mixers” for consistency.

 

5) Stereo input/stereo output matrix mixer modules have been added. These Stereo Matrixes allow routing a stereo signal from a single control. In all cases, the mute, connect, and fader control operate on stereo pairs.

 

6) Dedicated support for controlling SymNet with a CM Labs MotorMix control surface has been added (this requires a Control I/O). To support this, a new feature called virtual mixers has been added. Virtual mixers allow dealing with control surfaces without having to manage individual controller numbers.

 

7) For CobraNet, low latency modes are now supported. On CobraLink and Express Cobra units, these can be accessed from the Unit Properties, CobraNet Options dialog. Note that all CobraNet devices (Symetrix and 3rd party) must be configured for the same latency mode to communicate.
Note: For CobraLink devices, CM-1 firmware V2.9.6 or newer is required for low latency support.

 

8) For CobraNet, 24-bit support has been added. This is selected from either the New CobraNet Bundle or Edit CobraNet Bundle dialog.
Note: For CobraLink devices, CM-1 firmware V2.9.6 or newer is recommended.

 

9) For CobraNet, you can now select the number of channels in a bundle. This allows for more flexible routing of audio and better utilization of licensed channels. This is selected from either the New CobraNet Bundle or Edit CobraNet Bundle dialog.
Note: For CobraLink devices, CM-1 firmware V2.9.6 or newer is required to use more than 4 transmit or receive bundles.

 

10) An Auto upgrade button has been added to the Upgrade Firmware dialog box. This simplifies the process of upgrading firmware by automatically upgrading the Microprocessor and FPGA files of all connected units to the latest versions with a single click. In addition, on download, if a firmware version mismatch is detected, an option is given to immediately jump to the Upgrade Firmware dialog box.

 

11) The LED metering on the front panel of 8x8, 8in, and 8out DSP units has been enhanced with variable brightness levels. LEDs glow dimly for low-level signals and more brightly for higher-level signals providing better feedback on the level and dynamic characteristics of the audio. On 8x8 DSP units, the SIGNAL IN and SIGNAL OUT LEDs are dim at –48dBFS, medium brightness at –24dBFS, and full brightness at –12dBFS. On 8in and 8out DSP units, the bottom green LED come on at –48dBFS, the middle yellow LEDs are at medium brightness at –24dBFS and full brightness at –12dBFS. In all cases, the red clip LED still lights full brightness at just below 0dBFS.

 

12) A new group of control modules called radio buttons has been added. These modules allow choosing one of a group of preset control levels.

 

13) 32-input versions of the Gain and VCA modules have been added.

 

14) Control I/O firmware can now be upgraded using SymNet Designer. This feature is accessed through the Controller Manager, specifically the Edit Control I/O dialog box, Upgrade Firmware button.

 

15) Several DSP modules were made more efficient so that they utilize less DSP power. These include compressors, AGCs, expanders, gates, automixer combiners, VCAs, and control meters.

 

16) A new menu item, Site Properties, has been added to the Edit Menu. This item brings up the Site Properties dialog, which allows specifying DSP Optimization and IP settings. These settings used to be global but are now specific to a site file. (See the next two items for more detail.)

 

17) Unit IP addresses are now stored in the site file rather than in the PC’s registry. This simplifies administering multiple sites from the same PC. Ethernet settings can be accessed through Edit->Site Properties dialog.

 

18) DSP Optimization settings, which used to be global and reside in the Preferences dialog box, are now specific to a site file and have been moved to the Site Properties dialog box (Edit menu). This prevents problems with mismatched settings when moving site files between PCs.

 

19) Improvements have been made that make it more likely that “difficult” designs will successfully compile without manual intervention. Routing between DSPs is now more efficient so that it uses fewer DSP resources. In addition, in the “Minimize Routing Delays” DSP optimization mode, the placement algorithm has been improved to fix many problems where compiling fails even when considerable DSP is apparently available.

 

20) A new feature allows assigning multiple parameters to sequential RS-232/485 numbers in a single operation. You can assign groups of controls such as all faders, all mutes, or all controls to controller numbers in modules such as mixers and matrixes. This can greatly speed up the process of assigning controllers to these modules.

 

21) Parameters in the input and output modules (e.g. input gain) now can be assigned to presets.

 

22) All controls on a control screen can now be stored to a preset in one operation. This provides a very simple way of assigning just a selected group of controls to a preset. This option is available by right clicking in blank space in a control screen.

 

23) The color scheme for externally controlled or preset parameters has been changed. In previous versions, any parameter externally controlled or assigned to a preset was highlighted in green. Now, externally controlled parameters remain green but preset parameters are magenta instead. If a parameter is both externally controlled and preset, it is green.

 

24) Optimizations have improved editing speed, especially when working on the configuration view (top level) of large site files.

 

25) A new preference option has been added to allow turning off the undo feature in the configuration view (top level). Turning this off can dramatically speed up editing very large designs. WARNING: when turning off undo, remember to save often!

 

26) Modules and most other objects that have Notes are now indicated with a red upper-right corner. Clicking on the red corner automatically opens up the Notes for reading or editing.

 

27) In the Event Manager dialog, events can be sorted by clicking the column headings.

 

28) The Event Manager command has been moved to the Tools menu.

 

29) In the ARC Preset Menu dialog, preset names are now displayed in addition to preset numbers for added convenience.

 

30) SymNet Designer remembers the last used path for firmware upgrades and opening/saving site files, super-modules, settings files, and RS-485 files. When performing an operation that would change this path, e.g. saving a file in a new location, you are now presented with a dialog box that gives you the option to keep the existing path or change the default to the new path.

 

31) Saved super-modules now independently retain their default colors. Previously, all super-modules appeared dark green.

 

32) For CobraLink and Express Cobra units, the CobraNet firmware version (“Cobra Interface Firmware Version”) is now displayed in the Upgrade Firmware dialog box.

 

33) Some module default colors have been changed. Many modules that were previously gray by default are now colored.

 

34) The displayed precision for delay modules has been increased so it shows thousandths of milliseconds.

 

Terminology changes

In SymNet Designer V5.0, we have changed some terminology to increase clarity.

 

1) Mono Mixers are now called Mono/Mono Mixers to reflect the convention of Input format/Output format.

 

2) Stereo Mixers are now called Mono/Stereo Mixers to reflect the convention of Input format/Output format.

 

II) Installation Notes

 

If you are upgrading at an existing installation that loads a configuration automatically on start-up, the following procedure is recommended:

 

1. Make sure you have a copy of the original site file (.sym file). If it exists on your local drive, skip to step #2. Otherwise, open SymNet Designer 4.0 and choose Hardware->Upload Entire Site File from SymNet. This will save the file to your local drive.

2. Turn off the automatic configuration load by going to Upgrade Firmware, clicking on Erase Memory, selecting only “Triggers and Power on Default” and hitting Erase. Repeat for all connected units.

3. Upgrade the firmware as described below.

4. Re-download your entire site file to the hardware. Open the site file it in SymNet Designer 5.0 and choose Hardware->Download Entire Site File to SymNet (or press F4).

Following the re-download procedure listed above guarantees that the DSP code running in your hardware is the correct version to work with the new firmware and SymNet Designer application code.

 

Version 5.0 installs to a separate location than from previous versions on your hard drive. Version 5.0 will not interfere with your Version 1.x, 2.0, 3.x, or 4.0 settings. Version 5.0 can cohabitate with previous versions on your PC. It is important to note, however, that the firmware on the hardware must match the version of SymNet Designer that communicates with it. Version 5.0x will only communicate with hardware that is running the firmware released with Version 5.0x, etc.. If you intend to switch between versions of SymNet Designer while using the same hardware, you must remember to change the firmware each time. SymNet Designer checks this on download and warns you if a mismatch is detected.

 

III) Upgrading Firmware for V5.0

 

IMPORTANT: In order to run SymNet Designer version 5.0, the firmware in your hardware devices must be upgraded to the latest level. If you are receiving this software with a new SymNet device from the factory, then the firmware versions should already be correct. However, if you are using it with an existing SymNet device, then the firmware must be upgraded. (Information about the latest release versions is always available on the SymNet web site.) When you try to download a design to SymNet hardware, the firmware versions will be automatically checked and you will be told if an upgrade is required.

Note that there are "Verify" buttons in the Upgrade Firmware dialog for the Microprocessor and FPGA files. These allow verifying that the Microprocessor and FPGA firmware files in your hardware exactly match the files on your hard disk.

NOTE: For CobraLink units, there is also firmware from Peak Audio running on a daughter card inside the unit. You may need to upgrade this firmware as well. See “Upgrading CobraNet Firmware using CobraNet Discovery” below for instructions.

 

Current Versions

As of this writing, the current versions of the SymNet firmware are as follows:

SymNet Microprocessor file: Version 5.006 (applies to SymNet DSP, CobraLink, and BreakIn/Out devices.)

SymNet DigIO/Express Microprocessor file: Version 5.006 (applies to SymNet DigIO and Express devices.)

SymNet FPGA file for SymNet DSP Devices: Version 5.000

SymNet FPGA file for CobraLink Devices: Version 5.000

SymNet FPGA file for BreakIn/Out Devices: Version 5.000

SymNet FPGA file for DigIO Devices: Version 5.000

SymNet FPGA file for Express Devices: Version 5.000

 (See "Why are there two different files?" below for more information.)

 

Upgrading Firmware using Auto Upgrade

1.      Follow the step above under II) Installation Notes above.

2.      Install SymNet Designer 5.0 using the provided Setup utility. This will copy the necessary firmware files to your hard drive.

3.      Launch SymNet Designer 5.0.

4.      Connect your hardware devices as they would be for normal operation. Disconnect or power down all audio devices, especially power amps and speakers, connected to SymNet during the upgrade.

5.      In SymNet Designer 5.0, choose Hardware -> Upgrade Firmware. Press the Auto Upgrade button. This will upgrade all connected units. If you want, you can verify the correct versions on the connected units. Click the Close button when you are finished.

If you encounter problems with this procedure, try the manual operation procedure below.

 

Upgrading Firmware – manual operation

1.      Follow the step above under II) Installation Notes above.

2.      Install SymNet Designer 5.0 using the provided Setup utility. This will copy the necessary firmware files to your hard drive.

3.      Launch SymNet Designer 5.0.

4.      Connect your hardware devices as they would be for normal operation. Disconnect or power down all audio devices, especially power amps and speakers, connected to SymNet during the upgrade.

5.      In SymNet Designer 5.0, choose Hardware -> Upgrade Firmware. The dialog that appears will tell you the version of the firmware in your hardware devices.

6.      Click the Upgrade button under SymNet Microprocessor file. An open file dialog will appear allowing you to navigate for firmware files. By default it should take you into the C:\Program Files\Symetrix\SymNet Designer 5.0\Upgrade folder. Select the file SymNet_MicroProc_V5006.bin and click Open. (If you are using a DigIO or Express, select that file instead.)

7.      After this finishes, click the Upgrade button under SymNet FPGA file. Select the SymNet_FPGA_V5000.bit file and click Open. (If you are upgrading a CobraLink, BreakIn/Out, DigIO, or Express device, select the respective file instead.)

8.      If you have more than one SymNet device, select each device using the address dropdown at the top of the dialog box and repeat steps 5-6.

9.      If you are using CobraLink or Express Cobra and have more than one ring, also repeat for all devices on all rings using the Ring dropdown at the top of the dialog box.

10.     When finished, click Close.

 

Why are there two different files?

SymNet firmware has two components, the microprocessor file and the FPGA file. They are generally independent and both may need upgrading.

The microprocessor file contains the code that SymNet's embedded microprocessor runs. This microprocessor is responsible for communicating with the host, managing the DSPs, external control, and many other tasks. One version of the microprocessor file is common to all SymNet devices other than the DigIO and Express, i.e. SymNet DSP, CobraLink, and Break In/Out devices. A second microprocessor file is used with both DigIO and Express devices. The microprocessor file for these devices is prefixed with DigIO_Express_MicroProc. The file for all other devices is prefixed with SymNet_MicroProc. In both cases, the version number is contained in the file name.

The FPGA (Field Programmable Gate Array) file controls the programmable logic devices used in SymNet. These devices manage the SymLink bus, handle audio I/O, facilitate DSP communication, and perform several other tasks. The FPGA file is common to all SymNet DSP devices (i.e. 8x8, 8in, 8out). However, a different file is required for each of the CobraLink, BreakIn/Out, DigIO, and Express devices. The file intended for SymNet DSP devices is prefixed with SymNet_DSP_FPGA. The file intended for CobraLink devices is prefixed with CobraLink_FPGA. The file intended for BreakIn/Out devices is prefixed with BreakIO_FPGA. The file intended for DigIO devices is prefixed with DigIO_FPGA. The file intended for Express devices is prefixed with Express_FPGA. In all cases, the version number is contained in the file name. By default, SymNet Designer only shows you files valid for your particular unit and additionally checks the file contents to prevent you from using the wrong type of FPGA file.

 

Upgrading CobraNet Firmware using CobraNet Discovery

To take advantage of some new CobraNet features in SymNet Designer such as low latency, CobraLink units need to have CobraNet interface firmware V2.9.6 or later. You can check the version of firmware running on your CobraLink unit using SymNet Designer. It is listed in the Upgrade Firmware dialog after “Cobra Interface Firmware Version”. If you need to upgrade the firmware, follow these steps.

 

1.             Download and install CobraNet Discovery (aka “Disco”), Peak Audio’s utility for upgrading CobraNet firmware and monitoring a CobraNet network. This software is available from http://www.peakaudio.com/Download.html. More information and help on Disco is available at http://www.peakaudio.com/downloads/Disco_Manual/Disco3.0.2_Manual.htm.

2.             Obtain the latest CobraLink CM-1 firmware from the Symetrix web site (Downloads page). Unzip and copy the file to the CobraNet Discovery\firmware directory. By default, this is C:\Program Files\Peak Audio\CobraNet Discovery\firmware.

3.             Launch CobraNet Discovery and power up all CobraLink units. All units must be attached to a network that can be “seen” by the PC running Disco.

4.             For each unit, assign an IP address by right clicking and choosing New IP Address. The assigned address must be in the same sub-net as the PC running Disco.

5.             For each unit, upgrade the firmware by right clicking and choosing Update Firmware. Select Symetrix CobraLink version 2.9.6.

6.             When prompted, power cycle each unit.

 

IV) Issues with Site files from previous versions of SymNet Designer

 

In version 5.0, the site file (.sym file) format has changed from previous versions. You will be able to open all previous version site files in V5.0 or later. However, files saved with version 5.0 will not be readable by previous versions.

 

If you are working with site files from version 3.5x or older, there are some additional issues. Since version 3.5x and older site files supported eight configurations instead of only one, you must choose the configuration to load when opening site files from these older versions. When you first open a V3.5x or older site file in V5.0, the Select Configuration dialog box appears asking you which configuration you wish to load. (If a particular configuration was not used in that site file, “empty” is displayed after the configuration name.) After you select a configuration, the file is opened with the filename changed to indicate the selected configuration. For example, if the original site file was named My Site.sym and you selected Configuration 1, the new filename would be My Site-Configuration1.sym. If your older site files use only one configuration, opening and re-saving once is all that is required to convert them to V5.0 format. If they use more than one configuration, you must repeat the process for all configurations. For example, if a previous-version site file used 3 configurations, you would need to open it 3 times, once for each used configuration. The result would be 3 new V5.0 site files. Note that the Select Configuration dialog box displays “empty” after any configuration that was unused in the older site file to aid in determining how may configurations your file used.

 

If you intend to maintain both V5 and previous versions on your computer, we recommend the following guidelines to minimize difficulties with file formats:

A) Backup all previous version design files.
B) Don't use the same file names for Version 5.0 design files.
C) Choose the default locations when installing software.
D) Do not use version 5.0 software with previous versions of firmware or previous versions of software with version 5.0 firmware.

A) Backup all previous version design files.

It is recommended that you backup your version 4.x or earlier design files to a secure location before using or installing Version 5.0. Even if all else goes completely wrong, as long as you have those files, there is a way to recreate your old setup. Note that once you save a file with SymNet Designer 5.0 and overwrite a file from a previous version, it will no longer be readable in the previous version of SymNet Designer.

 

B) Don't use the same file names for Version 5.0 design files.

If you are going to maintain both versions of the software on your PC, it is highly recommended that you include something in the file name of all previous version files you save to indicate their version. This way you will be able to tell the files apart if they become co-mingled.

Even if you are not going to maintain both versions, it is a good idea to use this practice at least until all your design files have been converted and you have fully embraced Version 5.0.

 

C) Choose the default locations when installing software.

When you install any version of SymNet Designer software, allow the installation to go to the default folder. This ensures that multiple versions will not interfere with each other.

 

D) Do not use version 5.0 software with previous versions of firmware or previous versions of software with version 5.0 firmware.

The versions of software and firmware must match! The only operation that accesses hardware you should do with mismatched software and firmware is to upgrade to the correct firmware. Upgrading is generally possible regardless of the firmware mismatch. If this is not the case, the release notes will make a point of mentioning this.