SymNet Designer Version 6.02 Release Notes

Copyright 2006, Symetrix, Inc.

Updated: April 19, 2006

 

Overview of contents of this file

Introduction

I) Changes from previous versions

II) Installation Notes

III) Upgrading Firmware for V6.0

IV) Issues with Site files from previous versions of SymNet Designer

 

Introduction

 

This document is intended for those users upgrading from Version 5.5x. If you are upgrading from an earlier version, you may also want to review the release notes from the relevant intermediate releases (e.g. V5.0, V4.0, V3.5, etc.). These can be found on the SymNet web site.

 

I) Changes from previous versions

Changes in V6.02 from V6.01

SymNet Designer V6.02 is a maintenance release for version 6.01. It is recommended that all users of V6.01 with SymNet Express units upgrade to V6.02.

1) A problem was fixed where output distributor and output selector modules on SymNet Express units didn’t work correctly in certain designs. The problem usually manifested itself in the even-numbered outputs putting out no audio.

 

Changes in V6.01 from V6.0

SymNet Designer V6.01 is a maintenance release for version 6.0. It is recommended that all users of V6.0 upgrade to V6.01.

1) A problem was fixed where the number of CobraNet channels displayed in the ‘Upgrade Firmware’ window was incorrect for some Express Cobra units.

 

2) Various improvements and corrections were made to the Help file.

 

3) A minor display problem on oscilloscope modules was fixed.

 

Main New V6.0 Features (compared to V5.5x)

SymNet Designer V6.0 is a major release and has many enhancements compared to V5.5x.

 

1) New conferencing echo cancelling modules have been added. These modules provide echo cancelling and noise reduction with various numbers of inputs. Several sample rates are offered to allow trading off audio bandwidth and DSP utilization.

 

2) A new control module that can output RS-232 strings has been added. The RS-232 String Output module, found under Control Modules->Control Outputs, can be used to send an arbitrary text or binary string out a unit’s RS-232 port when a control event occurs. This may be used to control 3rd party devices that accept RS-232 commands, such as projectors and automated screens. The string may be up to 63 characters in length. Special and arbitrary characters (e.g. carriage return, line feed, etc.) are supported in addition to standard text.

 

3) To support #2 above, a new accessory serial port option called ‘Deaf Mode’ has been added, accessible via Hardware->Upgrade Firmware, Accessory Port Settings button. When this command is enabled, SymNet hardware devices will not respond to RS-232 commands received on their accessory ports. This is to prevent SymNet from acting on acknowledgements or other data sent by third party RS-232 devices. We recommend enabling deaf mode whenever a third party device is being controlled from a SymNet accessory port.

 

4) Several new icons have been added under ‘External Devices’ for better documenting systems. These include several different microphones, mixers, headphones, and touch-screen panels.

 

5) Many new Super-modules are now included in the installer. These are installed in the SymNet Designer 6.0\Super-Module directory. Super-modules can be added to designs by choosing Tools->Super-module Manager and pressing the Import button. The new Super-modules include DTMF dialer, several input processing blocks, and a bunch of toys such as reverb, metronome, ocean noise generator, and car alarm.
In addition, a document describing all the included super-modules is included. Look for the shortcut under Start->Programs->SymNet Designer->6.0 called “SymNet Designer Super-module Info”.

 

6) A new menu item called ‘Site Ethernet Preferences’ as been added to the ‘Edit’ menu. It brings up the ‘Ethernet Preferences’ window for editing. This is a shortcut to this window which is also accessible from the Site Properties window.

 

7) Notes fields now automatically wrap to the size of the window, making it easier to add and edit documentation.

 

8) Several internal program changes have been made to optimize memory usage and provide more internal routing resources.  This may help “difficult” designs compile more easily.

 

II) Installation Notes

 

If you are upgrading at an existing installation that loads a configuration automatically on start-up, the following procedure is recommended:

 

1. Make sure you have a copy of the original site file (.sym file). If it exists on your local drive, skip to step #2. Otherwise, open SymNet Designer 5.0 and choose Hardware->Upload Entire Site File from SymNet. This will save the file to your local drive.

2. Turn off the automatic configuration load by going to ‘Upgrade Firmware’, clicking on ‘Erase Memory’, selecting only ‘Triggers and Power on Default’ and pressing Erase. Repeat for all connected units.

3. Upgrade the firmware as described below.

4. Re-download your entire site file to the hardware. Open the site file it in SymNet Designer 6.0 and choose Hardware->Download Entire Site File to SymNet (or press F4).

Following the re-download procedure listed above guarantees that the DSP code running in your hardware is the correct version to work with the new firmware and SymNet Designer application code.

 

Version 6.0 installs to a separate location than from previous versions on your hard drive. Version 6.0 will not interfere with your Version 1.x, 2.0, 3.x, 4.0, or 5.x settings. Version 6.0 can cohabitate with previous versions on your PC. It is important to note, however, that the firmware on the hardware must match the version of SymNet Designer that communicates with it. Version 6.0 will only communicate with hardware that is running the firmware released with Version 6.0x, etc. If you intend to switch between versions of SymNet Designer while using the same hardware, you must remember to change the firmware each time. SymNet Designer checks this on download and warns you if a mismatch is detected.

 

III) Upgrading Firmware for V6.0

 

IMPORTANT: In order to run SymNet Designer version 6.0, the firmware in your hardware devices must be upgraded to the latest level. If you are receiving this software with a new SymNet device from the factory, then the firmware versions should already be correct. However, if you are using it with an existing SymNet device, then the firmware must be upgraded. (Information about the latest release versions is always available on the SymNet web site.) When you try to download a design to SymNet hardware, the firmware versions will be automatically checked and you will be told if an upgrade is required.

Note that there are ‘Verify’ buttons in the ‘Upgrade Firmware’ dialog for the Microprocessor and FPGA files. These allow verifying that the Microprocessor and FPGA firmware files in your hardware exactly match the files on your hard disk.

NOTE: For CobraLink and Express Cobra units, there is also firmware from Peak Audio that controls the CobraNet features. You may need to upgrade this firmware as well. See Upgrading CobraNet Firmware using CobraNet Discovery below for instructions.

 

Current Versions

As of this writing, the current versions of the SymNet firmware are as follows:

SymNet Microprocessor file: Version 6.001 (applies to SymNet DSP, CobraLink, and BreakIn/Out devices.)

SymNet DigIO/Express Microprocessor file: Version 6.001 (applies to SymNet DigIO and Express devices.)

SymNet FPGA file for SymNet DSP Devices: Version 6.000

SymNet FPGA file for CobraLink Devices: Version 6.000

SymNet FPGA file for BreakIn/Out Devices: Version 6.000

SymNet FPGA file for DigIO Devices: Version 6.000

SymNet FPGA file for Express Devices: Version 6.000

 (See Why are there two different files? below for more information.)

 

Upgrading Firmware using Auto Upgrade

1.       Follow the step above under II) Installation Notes above.

2.       Install SymNet Designer 6.0 using the provided Setup utility. This will copy the necessary firmware files to your hard drive.

3.       Launch SymNet Designer 6.0.

4.       Connect your hardware devices as they would be for normal operation. Disconnect or power down all audio devices, especially power amps and speakers, connected to SymNet during the upgrade.

5.       In SymNet Designer 6.0, choose Hardware->Upgrade Firmware. Press the Auto Upgrade button. This will upgrade all connected units. If you want, you can verify the correct versions on the connected units. Click the ‘Close’ button when you are finished.

If you encounter problems with this procedure, try the manual operation procedure below.

 

Upgrading Firmware – manual operation

1.       Follow the step above under II) Installation Notes above.

2.       Install SymNet Designer 6.0 using the provided Setup utility. This will copy the necessary firmware files to your hard drive.

3.       Launch SymNet Designer 6.0.

4.       Connect your hardware devices as they would be for normal operation. Disconnect or power down all audio devices, especially power amps and speakers, connected to SymNet during the upgrade.

5.       In SymNet Designer 6.0, choose Hardware->Upgrade Firmware. The dialog that appears will tell you the version of the firmware in your hardware devices.

6.       Click the ‘Upgrade’ button under SymNet Microprocessor file. An open file dialog will appear allowing you to navigate for firmware files. By default it should take you into the C:\Program Files\Symetrix\SymNet Designer 6.0\Upgrade folder. Select the file SymNet_MicroProc_V6001.bin and click ‘Open’. (If you are using a DigIO or Express, select that file instead.)

7.       After this finishes, click the ‘Upgrade’ button under SymNet FPGA file. Select the SymNet_FPGA_V6000.bit file and click ‘Open’. (If you are upgrading a CobraLink, BreakIn/Out, DigIO, or Express device, select the respective file instead.)

8.       If you have more than one SymNet device, select each device using the address dropdown at the top of the dialog box and repeat steps 5-6.

9.       If you are using CobraLink or Express Cobra and have more than one ring, also repeat for all devices on all rings using the Ring dropdown at the top of the dialog box.

10.   When finished, click ‘Close’.

 

Why are there two different files?

SymNet firmware has two components, the microprocessor file and the FPGA file. They are generally independent and both may need upgrading.

The microprocessor file contains the code that SymNet's embedded microprocessor runs. This microprocessor is responsible for communicating with the host, managing the DSPs, external control, and many other tasks. One version of the microprocessor file is common to all SymNet devices other than the DigIO and Express, i.e. SymNet DSP, CobraLink, and Break In/Out devices. A second microprocessor file is used with both DigIO and Express devices. The microprocessor file for these devices is prefixed with DigIO_Express_MicroProc. The file for all other devices is prefixed with SymNet_MicroProc. In both cases, the version number is contained in the file name.

The FPGA (Field Programmable Gate Array) file controls the programmable logic devices used in SymNet. These devices manage the SymLink bus, handle audio I/O, facilitate DSP communication, and perform several other tasks. The FPGA file is common to all SymNet DSP devices (i.e. 8x8, 8in, 8out). However, a different file is required for each of the CobraLink, BreakIn/Out, DigIO, and Express devices. The file intended for SymNet DSP devices is prefixed with SymNet_DSP_FPGA. The file intended for CobraLink devices is prefixed with CobraLink_FPGA. The file intended for BreakIn/Out devices is prefixed with BreakIO_FPGA. The file intended for DigIO devices is prefixed with DigIO_FPGA. The file intended for Express devices is prefixed with Express_FPGA. In all cases, the version number is contained in the file name. By default, SymNet Designer only shows you files valid for your particular unit and additionally checks the file contents to prevent you from using the wrong type of FPGA file.

 

Upgrading RS-485 device firmware

New releases may include new firmware versions for Symetrix RS-485 devices such as the Control I/O, Modular ARC family, and ARC-II. If new firmware is provided, it will usually be listed in the release notes section. To upgrade RS-485 device firmware, follow these steps.

 

1.       Follow the step above under II) Installation Notes above.

2.       Install SymNet Designer 6.0 using the provided Setup utility. This will copy the necessary firmware files to your hard drive.

3.       Launch SymNet Designer 6.0.

4.       Connect your RS-485 devices as they would be for normal operation. RS-485 devices must have unique addresses (set by DIP or rotary switches on the units, see the appropriate hardware Quick Start Guide for more information).

5.       If you are working with an existing site file that includes the RS-485 devices, open that site file.

6.       Choose Tools->Controller Manager. If your RS-485 devices are not listed under ‘RS-485 Controller Network’, you will need to add them. This can either be done manually using the ‘New RS-485 Device…’ button, or by sensing what units are connected using the ‘<< Upload’ button.

7.       For each RS-485 device that you wish to upgrade, select the device and click the Edit… button. In the dialog box that appears, click the ‘Upgrade Firmware…’ button. Choose the appropriate firmware file and press ‘Open’.  (You may also use ‘Verify Firmware’ to determine if upgrading is necessary.)

8.       Press ‘OK’ and continue to the next RS-485 device, if there are more.

 

Upgrading CobraNet Firmware using CobraNet Discovery

To take advantage of some new CobraNet features in SymNet Designer such as low latency, CobraLink units need to have CobraNet interface firmware V2.9.6 or later. Express Cobra units should use firmware V2.10.6 or later. However, these are minimums and it is advisable to use the most recent firmware which as of this writing, are V2.9.14 for CobraLink and 2.11.2 for Express Cobra. You can check the version of firmware running on your CobraLink unit using SymNet Designer. It is listed in the ‘Upgrade Firmware’ dialog after ‘Cobra Interface Firmware Version’. If you need to upgrade the firmware, follow these steps.

 

1.       Download and install CobraNet Discovery (aka “Disco”), Peak Audio’s utility for upgrading CobraNet firmware and monitoring a CobraNet network. This software is available from http://www.peakaudio.com/Download.html. More information and help on Disco is available at http://www.peakaudio.com/downloads/Disco_Manual/Disco3.0.2_Manual.htm.

2.       Obtain the latest CobraLink CM-1 or Express firmware from the SymNet web site. Unzip and copy the file to the CobraNet Discovery\firmware directory. By default, this is C:\Program Files\Peak Audio\CobraNet Discovery\firmware.

3.       Launch CobraNet Discovery and power up all CobraLink or Express Cobra units. All units must be attached to a network that is visible by the PC running Disco.

4.       For each unit, assign an IP address by right clicking and choosing New IP Address. The assigned address must be in the same sub-net as the PC running Disco.

5.       For each unit, upgrade the firmware by right clicking and choosing Update Firmware. Select Symetrix CobraLink version 2.9.14 for CobraLink units and Express version 2.11.2 for Express Cobra.

6.       When prompted, power cycle each unit.

 

IV) Issues with Site files from previous versions of SymNet Designer

 

In version 6.0, the site file (.sym file) format has changed from previous versions. You will be able to open all previous version site files in V6.0 or later. However, files saved with version 6.0 will not be readable by previous versions.

 

If you are working with site files from version 3.5x or older, there are some additional issues. Since version 3.5x and older site files supported eight configurations instead of only one, you must choose the configuration to load when opening site files from these older versions. When you first open a V3.5x or older site file in V6.0, the Select Configuration dialog box appears asking you which configuration you wish to load. (If a particular configuration was not used in that site file, ‘empty’ is displayed after the configuration name.) After you select a configuration, the file is opened with the filename changed to indicate the selected configuration. For example, if the original site file was named My Site.sym and you selected Configuration 1, the new filename would be My Site-Configuration1.sym. If your older site files use only one configuration, opening and re-saving once is all that is required to convert them to V6.0 format. If they use more than one configuration, you must repeat the process for all configurations. For example, if a previous-version site file used 3 configurations, you would need to open it 3 times, once for each used configuration. The result would be 3 new V6.0 site files. Note that the Select Configuration dialog box displays ‘empty’ after any configuration that was unused in the older site file to aid in determining how many configurations your file used.

 

If you intend to maintain both V6.0 and previous versions on your computer, we recommend the following guidelines to minimize difficulties with file formats:

A) Backup all previous version design files.
B) Don't use the same file names for Version 6.0 design files.
C) Choose the default locations when installing software.
D) Do not use version 6.0 software with previous versions of firmware or previous versions of software with version 6.0 firmware.

A) Backup all previous version design files.

It is recommended that you backup your version 5.0x or earlier design files to a secure location before using or installing Version 6.0. Even if all else goes completely wrong, as long as you have those files, there is a way to recreate your old setup. Note that once you save a file with SymNet Designer 6.0 and overwrite a file from a previous version, it will no longer be readable in the previous version of SymNet Designer.

 

B) Don't use the same file names for Version 6.0 design files.

If you are going to maintain both versions of the software on your PC, it is highly recommended that you include something in the file name of all previous version files you save to indicate their version. This way you will be able to tell the files apart if they become co-mingled.

Even if you are not going to maintain both versions, it is a good idea to use this practice at least until all your design files have been converted and you have fully embraced Version 6.0.

 

C) Choose the default locations when installing software.

When you install any version of SymNet Designer software, allow the installation to go to the default folder. This ensures that multiple versions will not interfere with each other.

 

D) Do not use version 6.0 software with previous versions of firmware or previous versions of software with version 6.0 firmware.

The versions of software and firmware must match! The only operation that accesses hardware you should do with mismatched software and firmware is to upgrade to the correct firmware. Upgrading is generally possible regardless of the firmware mismatch. If this is not the case, the release notes will make a point of mentioning this.